Topaz glitch with latest CC

Discussion in 'Post Processing' started by Ben Egbert, Sep 18, 2019.

  1. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    Topaz has a glitch after the last upgrade to CC. My actions open and apply, but only after a long delay. around 1-2 minutes.

    I have tried updating Topaz, but am not able to get a password. Still working that.

    I have looked for where the plug-ins were located, they are now supposed to be in Program files (x86)>common files>Adobe>plug ins>CC

    I found some pug ins in the Topaz folder and copied them to the CC folder buy probably not in the correct format.

    Alan, you use Topaz, have you had this issue? I don't use LR, so this is when I try to go to Topaz from Photoshop under filters.
     
  2. AlanLichty

    AlanLichty Moderator

    Joined:
    Aug 16, 2017
    Messages:
    10,617
    Likes Received:
    8,639
    Location:
    Vancouver, Washington
    Home Page:
    I am not having issues with any of my Topaz plugins or with Studio (both v1 and v2) when accessing via photoshop. I do not have actions that launch any of the Topaz filters.

    All of my Topaz plugins are located in separate folders within the Applications folder (MacOS). Your reference for the location looks like the Windows file system. I have had to restart Photoshop after each Topaz update (there have been a lot this summer).

    topaz.jpg

    I would contact Topaz and request help - they have very good customer support.
     
    Ben Egbert likes this.
  3. JimFox

    JimFox Moderator
    Staff Member

    Joined:
    Jul 19, 2017
    Messages:
    14,656
    Likes Received:
    10,283
    Location:
    SoCal
    Home Page:
    Topaz is working in Photoshop CC fine for me.

    When did this start? Had you changed anything? Or installed anything new?
     
  4. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    Thanks Alan. I am having trouble signing into Topaz, but as soon as I resolve that, I will ask.

    Jim, I just installed an Avast update, and I think a new Windows 10 update was also done recently, a major one. So you bit the bullet and got CC?
     
  5. JimFox

    JimFox Moderator
    Staff Member

    Joined:
    Jul 19, 2017
    Messages:
    14,656
    Likes Received:
    10,283
    Location:
    SoCal
    Home Page:
    Yeah, I had to get it maybe 6 months ago. I was getting tired of the 2 step process with using the DNG converter, which worked, but I wanted to go back to directly editing the raw in ACR. Getting the Sony A6400 which also wasn’t covered in CS6, was the final straw.

    And I think I had more then gotten my money’s worth out of CS6, so I didn’t have any hard feelings of finally biting the bullet and getting Photoshop CC.
     
    Ben Egbert likes this.
  6. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    I submitted a request for support which I was able to do without a log in. I have gotten good support before. I wonder if Avast is blocking it? I will see.
     
  7. JimFox

    JimFox Moderator
    Staff Member

    Joined:
    Jul 19, 2017
    Messages:
    14,656
    Likes Received:
    10,283
    Location:
    SoCal
    Home Page:
    Avast could be the issue, let us know what you find out.
     
  8. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    I got the password fixed, they assigned me one at their end. Still working on the other problem. Might uninstall and start with a fresh download, waiting for a reply, probably tomorrow. Avast does not seem to be blocking anything.
     
  9. JimFox

    JimFox Moderator
    Staff Member

    Joined:
    Jul 19, 2017
    Messages:
    14,656
    Likes Received:
    10,283
    Location:
    SoCal
    Home Page:
    By the way, is it all of your Topaz programs? Or just one causing the issue? I have like 3 Topaz Addons, and I run them separately.
     
  10. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    I have not tried them all, but it does effect Adjust, Studio and Studio 2. I need to try Denoize. I like to run them as an action from within Photoshop, That way I can find a few presets I like and use them and not have to figure out all the settings everytime. This last week I have been using them stand alone. I wanted to see how I liked Studio 2. Its is pretty good, but I have not found the presets I like and so far have not been able to duplicate them.

    I have remask, but never use it. I also never use the sharpening module, although I did at one time.. Looks like you get a lot of it in Studio 2.

    When I get Studio up and running I will ask some of you what settings you like.
     
  11. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    Ok, I seem to have all the Topaz stuff in my filter window in Photoshop. That is I have Studio and studio 2, and Denoize 6 and Denoize AI. So I checked and they are loaded in the correct CC folder. Denoize loades slow but does load. Denoize AI returns a fail to load message.

    I wonder if part of the problem might be having the old and new in the same place. I will wait until I get the ok from Toapz to uninstall and do a fresh install.
     
  12. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    Ok, here is where I am now. I got several replies from Topaz then it just stopped after repeated requests for follow up.

    I have my password fixed, but basically nothing else.

    The core issue is that the modules stall when selected at he Photoshop Filters window. They run fine is called from desktop.

    I uninstalled the problem modals and reinstalled them.

    I updated to the latest versions.

    It said I was eligible for Studio 2, and so I installed it, but it says I have 20 days left to purchase.

    I tried disabling Avast and running the programs, they still stall.

    I have rebooted several times.

    I had one incidence where they loaded fast and ran fine, next time it was back to stall.

    I have been playing with Topaz Adjust AI and Topaz Studio 2. I have learned about how to navigate the menus but so far, I have not found anything that is better than Studio 1 preset Color and contrast Boost 3. Or exposure in the old Adjust modual.

    I have even copied the setting for exposure, but the format is not the same as the Adjust AI.

    Just an update. I suppose I will continue to use them, maybe at the desktop level.
     
  13. AlanLichty

    AlanLichty Moderator

    Joined:
    Aug 16, 2017
    Messages:
    10,617
    Likes Received:
    8,639
    Location:
    Vancouver, Washington
    Home Page:
    Bummer this doesn't work directly from photoshop - I don't like using the standalone versions myself and exclusively use them either directly in Studio (AI Clear, Precision Contrast and HSL Color Tuning) or as filters from the photoshop drop down menus (Adjust AI, DeNoise AI, Clarity, ReStyle, and Sharpen AI). None of these last modules appear inside of Studio. I have created my own presets for a lot of these.

    For licensing on Studio you should be able to register by just entering your email address. If you sign onto the Topaz website you should be able to see all of your licensed products and how to register them.
     
  14. Ben Egbert

    Ben Egbert Forum Helper
    Staff Member

    Joined:
    Aug 19, 2017
    Messages:
    10,159
    Likes Received:
    6,725
    Location:
    American Fork Utah
    Home Page:
    Update. My ticket is still open, They appear to have a glitch with the license process which they have kicked up to the next level. I got a Studio 2 update and it has been working from within Photoshop. I have been playing with it, but don't have any of my own presets yet that I like. I have used some of the existing presets which work ok if I put them on a layer and reduce opacity. I am using Clarity and precision detail.

    I still have about 11 days on Studio 2, hopefully they will get the ownership thing fixed by then.
     

Share This Page

  • About Us

    Welcome to Focal World. As a Guest you have access to view the resources here. But it is totally FREE to Register and participate in the forums. If you find FocalWorld useful, please support it by Upgrading your Account to a Premium Account located in your Profile page. It is only $15 a year and will give you added ability of uploading photos directly from your computer and also the allows you to create your own Gallery's. We will be sharing the Daily Featured Photos on FaceBook, Instagram and in a Pbase Gallery to help share FocalWorld with others and to draw in new users as they view the incredible photos shared here. All photos share will include the name of the photographer who took them. If you do not want your photo to be shared in this method please let me know. But hopefully everyone will participate in helping to spread the word of FocalWorld in this manner. Thanks, Jim Fox